Nazi Zombie Portable
Please log in or register. If you're not logged in you cannot download maps.

Nazi Zombies Portable Official Community


You are not connected. Please login or register

Something is making my map not compile?

View previous topic View next topic Go down  Message [Page 1 of 1]

1 Something is making my map not compile? on Sun Apr 07, 2013 7:23 am

WillWow

avatar
I AM SPECIAL!
I AM SPECIAL!
Don't know what it is but ??? the worldcraft utility sometimes reports back with the error of the file not being there... IT IS SO ANNOOOOYYYYYIIIINNNG! Anyone know what is making the compiler break? It helps to know. Smilez

View user profile http://www.wheel-games.webs.com

2 Re: Something is making my map not compile? on Sun Apr 07, 2013 8:02 am

Tha best thing u can do is post here the complete LOG ^^


____________________________________________________________________________________________________
Der Riese WIP - My project for NZP
Valve Hammer Editor Setting up for mapping!

Actual Gaming Rig
View user profile

3 Re: Something is making my map not compile? on Sun Apr 07, 2013 12:13 pm

You probably have an invalid texture somewhere that might have a bad name, incluiding spaces and ilegal characters. Make sure the texture's names are only letters and has no spaces. Also, you might have gone to a texture and put "fit". That messes up because if you have a really thin block, it will also make the texture fit... But the texture cannot actually fit in REALLY small blocks (depending on the size of the texture) so it will give you an error message... Anyways, I suggest you to make backup or checkpoint .rmf's so that you don't throw all your work away... And also ALWAYS compile your maps right away after making changes, such as a house, that way if you make an error that you know where it's at... It's a smart idea, trust me... It's saved me so much time and effort. The only thing you need to do is compile the map and if you see an error, go back to the map and undo the things you recently did... and then compile it again, if the error is still there, keep deleting the things you made... That's why I suggest you that you compile your map right after a change you create. Even entities.. I've had problem with entities too. Make sure that the "info_player_start" and "info_player_deathmatch" are NOT touching each other, or else it will give you an error... Anyways hope this helps. If you keep having problems though, PM me and I'll try to help you through TV.

View user profile

4 Re: Something is making my map not compile? on Sun Apr 07, 2013 12:22 pm

Guest


Guest
We need a compile log, when the compiler window comes up, copy everything in it to here, but put it in a spoiler. :cute:

Then we can help you. :cute:

Your compiler log should look something like this:
Spoiler:



** Executing...
** Command: C:\vhe\Zhlt\hlcsg.exe
** Parameters: c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1 -nowadtextures

hlcsg v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlcsg -----
Command line: C:\vhe\Zhlt\hlcsg.exe c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1 -nowadtextures
Entering c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1.map

Current hlcsg Settings
Name | Setting | Default
---------------------|-----------|-------------------------
threads [ 2 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
max lighting memory [ 6291456 ] [ 6291456 ]
priority [ Normal ] [ Normal ]

noclip [ off ] [ off ]
null texture stripping[ on ] [ on ]
clipnode economy mode [ on ] [ on ]
clip hull type [ legacy ] [ legacy ]
onlyents [ off ] [ off ]
wadtextures [ off ] [ on ]
skyclip [ on ] [ on ]
hullfile [ None ] [ None ]
nullfile [ None ] [ None ]
min surface area [ 0.500 ] [ 0.500 ]
brush union threshold [ 0.000 ] [ 0.000 ]

Using mapfile wad configuration
Wadinclude list :
[zhlt.wad]

45 brushes (totalling 272 sides) discarded from clipping hulls
CreateBrush:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.28 seconds)
SetModelCenters:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.00 seconds)
CSGBrush:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (1.40 seconds)

Using Wadfile: \waw_hlbsp.wad
- Contains 0 used textures, 0.00 percent of map (157 textures in wad)
Using Wadfile: \quake_textures.wad
- Contains 1 used texture, 3.33 percent of map (1329 textures in wad)
Using Wadfile: \extract_wad.wad
- Warning: Larger than expected texture (348972 bytes): 'BERLIN_WALL_MET'
- Warning: Larger than expected texture (348972 bytes): 'BRIGHTMETAL'
- Warning: Larger than expected texture (348972 bytes): 'DBLDOORS'
- Contains 0 used textures, 0.00 percent of map (229 textures in wad)
Including Wadfile: \vhe\zhlt\zhlt.wad
- Contains 0 used textures, 0.00 percent of map (8 textures in wad)
Using Wadfile: \minecraft.wad
- Contains 29 used textures, 96.67 percent of map (144 textures in wad)

added 1 additional animating textures.
Texture usage is at 0.06 mb (of 4.00 mb MAX)
1.85 seconds elapsed

----- END hlcsg -----




** Executing...
** Command: C:\vhe\Zhlt\hlbsp.exe
** Parameters: c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1

hlbsp v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlbsp -----
Command line: C:\vhe\Zhlt\hlbsp.exe c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1

Current hlbsp Settings
Name | Setting | Default
-------------------|-----------|-------------------------
threads [ 2 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
priority [ Normal ] [ Normal ]

noclip [ off ] [ off ]
nofill [ off ] [ off ]
noopt [ off ] [ off ]
null tex. stripping [ on ] [ on ]
notjunc [ off ] [ off ]
subdivide size [ 240 ] [ 240 ] (Min 64) (Max 512)
max node size [ 1024 ] [ 1024 ] (Min 64) (Max 8192)


SolidBSP [hull 0] 500...795 (0.05 seconds)
BSP generation successful, writing portal file 'c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1.prt'
SolidBSP [hull 1] 500...735 (0.05 seconds)
SolidBSP [hull 2] 500...505 (0.03 seconds)
SolidBSP [hull 3] 500...752 (0.05 seconds)
0.89 seconds elapsed

----- END hlbsp -----




** Executing...
** Command: C:\vhe\Zhlt\hlvis.exe
** Parameters: c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1 -full

hlvis v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlvis -----
Command line: C:\vhe\Zhlt\hlvis.exe c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1 -full
308 portalleafs
869 numportals

-= Current hlvis Settings =-
Name | Setting | Default
-------------------|-----------|-------------------------
threads [ 2 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
max vis distance [ 0 ] [ 0 ]
priority [ Normal ] [ Normal ]

fast vis [ off ] [ off ]
full vis [ on ] [ off ]


BasePortalVis:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.10 seconds)
LeafThread:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (12.74 seconds)
average leafs visible: 193
g_visdatasize:11344 compressed from 12012
12.86 seconds elapsed

----- END hlvis -----




** Executing...
** Command: C:\vhe\Zhlt\hlrad.exe
** Parameters: c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1

hlrad v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlrad -----
Command line: C:\vhe\Zhlt\hlrad.exe c:\users\FRIIZY~1\desktop\PCVERS~1\nzp\maps\MINESH~1

-= Current hlrad Settings =-
Name | Setting | Default
--------------------|---------------------|-------------------------
threads [ 2 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
max lighting memory [ 6291456 ] [ 6291456 ]
priority [ Normal ] [ Normal ]

vismatrix algorithm [ Original ] [ Original ]
oversampling (-extra)[ off ] [ off ]
bounces [ 1 ] [ 1 ]
bounce dynamic light [ on ] [ on ]
ambient light [ 0.000 0.000 0.000 ] [ 0.000 0.000 0.000 ]
maximum light [ 255.000 ] [ 256.000 ]
circus mode [ off ] [ off ]

smoothing threshold [ 50.000 ] [ 50.000 ]
direct threshold [ 25.000 ] [ 25.000 ]
direct light scale [ 2.000 ] [ 2.000 ]
coring threshold [ 1.000 ] [ 1.000 ]
patch interpolation [ on ] [ on ]

texscale [ on ] [ on ]
patch subdividing [ on ] [ on ]
chop value [ 64.000 ] [ 64.000 ]
texchop value [ 32.000 ] [ 32.000 ]

global fade [ 1.000 ] [ 1.000 ]
global falloff [ 2 ] [ 2 ]
global light scale [ 1.000 1.000 1.000 ] [ 1.000 1.000 1.000 ]
global gamma [ 0.500 0.500 0.500 ] [ 0.500 0.500 0.500 ]
global light scale [ 1.000 ] [ 1.000 ]
global sky diffusion [ 1.000 ] [ 1.000 ]

opaque entities [ on ] [ on ]
sky lighting fix [ on ] [ on ]
incremental [ off ] [ off ]
dump [ off ] [ off ]

colour jitter [ 0.0 0.0 0.0 ] [ 0.0 0.0 0.0 ]
monochromatic jitter [ 0.0 0.0 0.0 ] [ 0.0 0.0 0.0 ]
softlight hack [ 0.0 0.0 0.0 0.0 ] [ 0.0 0.0 0.0 0.0 ]
diffuse hack [ on ] [ on ]
spotlight points [ on ] [ on ]

custom shadows with bounce light
[ off ] [ off ]
rgb transfers [ off ] [ off ]


[Reading texlights from 'C:\vhe\Zhlt\lights.rad']
[59 texlights parsed from 'C:\vhe\Zhlt\lights.rad']

1846 faces
Create Patches : 6035 base patches
0 opaque faces
41033 square feet [5908862.00 square inches]
44 direct lights

BuildFacelights:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (1.51 seconds)
visibility matrix : 2.2 megs
BuildVisLeafs:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (3.42 seconds)
MakeScales:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.69 seconds)
SwapTransfers:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.50 seconds)
Transfer Lists : 3235432 : 3.24M transfers
Indices : 2763460 : 2.64M bytes
Data : 12941728 : 12.34M bytes
Bounce 1 GatherLight:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.17 seconds)
FinalLightFace:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.21 seconds)
6.77 seconds elapsed

----- END hlrad -----

5 Re: Something is making my map not compile? on Sun Apr 07, 2013 12:30 pm

Call16-Podolski

avatar
Smart, Just like a Chap.
Smart, Just like a Chap.
Had this error ages ago. Just delete everything you added since your last compile, and try again. Probably a dodgy texture.

PFFT, who needs Logs?


____________________________________________________________________________________________________
View user profile

6 Re: Something is making my map not compile? on Sun Apr 07, 2013 9:57 pm

WillWow

avatar
I AM SPECIAL!
I AM SPECIAL!
@Manuel Valle7 wrote:You probably have an invalid texture somewhere that might have a bad name, incluiding spaces and ilegal characters. Make sure the texture's names are only letters and has no spaces. Also, you might have gone to a texture and put "fit". That messes up because if you have a really thin block, it will also make the texture fit... But the texture cannot actually fit in REALLY small blocks (depending on the size of the texture) so it will give you an error message...

I once did click fit, on these computer screens(animated) as an accident, but I resized it myself again later, so did that cancel the effect of the 'fit' action?

@Manuel Valle7 wrote:And also ALWAYS compile your maps right away after making changes, such as a house, that way if you make an error that you know where it's at... It's a smart idea, trust me... It's saved me so much time and effort. The only thing you need to do is compile the map and if you see an error, go back to the map and undo the things you recently did... and then compile it again, if the error is still there, keep deleting the things you made... That's why I suggest you that you compile your map right after a change you create.

Yeah, I do that to test and to see if there is an error(I know a lot about this already, I won a medal on computer skills last year, and the 'skills' are not just games! And I also make computer games too... same thing... compile, run, test,etc. ...)

@Manuel Valle7 wrote:Even entities.. I've had problem with entities too. Make sure that the "info_player_start" and "info_player_deathmatch" are NOT touching each other, or else it will give you an error... Anyways hope this helps. If you keep having problems though, PM me and I'll try to help you through TV.

With the entities I have no problem... (P.S. info_player_deathmatch is not even used in NZP) Also about you helping, no need, but thanks for asking!

The only thing that happens is it can't find the .bsp file, so I don't think that the compiler log will help. Here is the compiler log. The first error is 'token too large on line 5'.

Spoiler:
** Executing...
** Command: Change Directory
** Parameters: "c:\Program Files\NZP"


** Executing...
** Command: c:\Program Files\Worldcraft\quaketools\nomapversion.exe
** Parameters: c:\PROGRA~1\WORLDC~1\maps\DIERIS~1


** Executing...
** Command: C:\Program Files\Worldcraft\quaketools\txqbsp.exe
** Parameters: c:\PROGRA~1\WORLDC~1\maps\DIERIS~1

TxQBSP 1.12 -- Modified by Bengt Jardrup

Inputfile: c:\PROGRA~1\WORLDC~1\maps\DIERIS~1.map
Outputfile: c:\PROGRA~1\WORLDC~1\maps\DIERIS~1.bsp
------ LoadMapFile ------
************ ERROR ************
Token too large on line 5

Elapsed time : 0:00

Peak memory used : 0.2 MB

** Executing...
** Command: c:\Program Files\Worldcraft\quaketools\vis.exe
** Parameters: c:\PROGRA~1\WORLDC~1\maps\DIERIS~1

---- Vis 2.31 ---- Modified by Bengt Jardrup

************ ERROR ************
Error opening c:\PROGRA~1\WORLDC~1\maps\DIERIS~1.bsp: No such file or directory

Elapsed time : 0:00

** Executing...
** Command: c:\Program Files\Worldcraft\quaketools\light.exe
** Parameters: c:\PROGRA~1\WORLDC~1\maps\DIERIS~1

----- Light 1.43 ---- Modified by Bengt Jardrup

************ ERROR ************
Error opening c:\PROGRA~1\WORLDC~1\maps\DIERIS~1.bsp: No such file or directory

Elapsed time : 0:00

** Executing...
** Command: Copy File
** Parameters: "c:\program files\worldcraft\maps\die rise.bsp" "c:\Program Files\NZP\nzp\maps\Die_Rise.bsp"

The command failed. Windows reported the error:
"The system cannot find the file specified."

** Executing...
** Command: Copy File
** Parameters: "c:\program files\worldcraft\maps\die rise.pts" "c:\Program Files\NZP\nzp\maps\Die_Rise.pts"

The command failed. Windows reported the error:
"The system cannot find the file specified."

I will fix this, it has happened before so I should manage... but thanks for the tips.

EDIT(Oraki51): Please don't advertise your maps in a thread unrelated to it
EDIT(WillWow): kk...

View user profile http://www.wheel-games.webs.com

7 Re: Something is making my map not compile? on Sun Apr 07, 2013 11:35 pm

It's a texture problem... Make sure that you have good characters on the textures and that the place where you store them are not too big... For example you might have:
C:\Users\William\Desktop\<TextureFolderName>\
which will be easier and will not take up much space. It's easier. You might wanna move your textures.

View user profile

8 Re: Something is making my map not compile? on Mon Apr 08, 2013 12:03 am

WillWow

avatar
I AM SPECIAL!
I AM SPECIAL!
No I worked out the problem. I opened the die rise.map file in notepad++ and found line 7, it is the list of textures. I am not making a textures parts 1, 2 & 3 .wads and will have them convert, so I don't have so many textures in the textures list on line 7.

View user profile http://www.wheel-games.webs.com

9 Re: Something is making my map not compile? on Mon Apr 08, 2013 12:04 am

Ohh that's what I forgot to mention too -_- well just combine your wads using TexMex and you should be fine.

View user profile

10 Re: Something is making my map not compile? on Mon Apr 08, 2013 12:29 am

WillWow

avatar
I AM SPECIAL!
I AM SPECIAL!
I already fixed it!! Now I'm happy I can keep making my map.

View user profile http://www.wheel-games.webs.com

11 Re: Something is making my map not compile? on Mon Apr 08, 2013 12:30 am

I know you already fixed it, but I just wanted to point out that if you combine your textures (make sure there's not too many on one wad) so that you'll be able to use all the ones you want.

View user profile

12 Re: Something is making my map not compile? on Mon Apr 08, 2013 12:32 am

WillWow

avatar
I AM SPECIAL!
I AM SPECIAL!
Yeah I figured it out in the end. But it was good everyone had suggestions on the topic. Smilez

View user profile http://www.wheel-games.webs.com

13 Re: Something is making my map not compile? on Mon Apr 08, 2013 12:33 am

It's good everyone said stuff because that way if you get other errors you might know what to do you know.

View user profile

14 Re: Something is making my map not compile? on Mon Apr 08, 2013 12:33 am

WillWow

avatar
I AM SPECIAL!
I AM SPECIAL!
@Manuel Valle7 wrote:It's good everyone said stuff because that way if you get other errors you might know what to do you know.

I can't agree more.

Now we can probably say this topic is solved...

View user profile http://www.wheel-games.webs.com

15 Re: Something is making my map not compile? on Mon Apr 08, 2013 12:36 am

@WillWow wrote:
@Manuel Valle7 wrote:It's good everyone said stuff because that way if you get other errors you might know what to do you know.

I can't agree more.

Now we can probably say this topic is solved...
True and it could help other people in the forums too... But anyways I'm outties, lates. Hope I did good help to you, and to others here : )

View user profile

Sponsored content


View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum