Nazi Zombie Portable
Please log in or register. If you're not logged in you cannot download maps.

Nazi Zombies Portable Official Community


You are not connected. Please login or register

Map Wont Load!

View previous topic View next topic Go down  Message [Page 1 of 1]

1NZP 1.1 Map Wont Load! on Sun Apr 02, 2017 7:08 am

So I was making this map and finally got done with it and copied it to my Vita, but it won't enter the map. It loads fully, but then the loading bar disappears. It still continues to say "Loading: (mapname)", but it never enters the map. What am I doing wrong??

View user profile

2NZP 1.1 Re: Map Wont Load! on Sun Apr 02, 2017 9:39 am

What map are you trying to run? Maps based for the beta 1.1 release seems to don't work with the demo release of the game for some reason, and another thing, are you copying the file to nzp/maps folder and trying to load with console? For some reason NZP on vita is a bit limited. I'll be trying to help you with the Vita, I got one ^-^


____________________________________________________________________________________________________
Der Riese WIP - My project for NZP
Valve Hammer Editor Setting up for mapping!

Actual Gaming Rig
View user profile

3NZP 1.1 Re: Map Wont Load! on Sun Apr 02, 2017 11:10 am

I made the map myself using Worldcraft. I am playing on the new unofficial patch and I'm loading the map from the "Custom Maps" section. (I am playing on my Vita with ARK-2 by the way. I was unfortunate and updated my Vita when the latest update came out so no jailbreak for me.)



Last edited by jofishwright on Mon Apr 03, 2017 12:10 am; edited 2 times in total

View user profile

4NZP 1.1 Re: Map Wont Load! on Sun Apr 02, 2017 11:13 am

And apparently I can't quote right.

View user profile

5NZP 1.1 Re: Map Wont Load! on Sun Apr 02, 2017 1:39 pm

It's fine no problem, sad you updated the vita but it's ok, there's a possibility that 3.63 runs ARK or Adrenaline, try to mess with the compilers, the unofficial patch is like the DEMO release, so setup properly your compilers to fit HLBSP, that is supported by the game, old worldcraft is not good for it Frown


____________________________________________________________________________________________________
Der Riese WIP - My project for NZP
Valve Hammer Editor Setting up for mapping!

Actual Gaming Rig
View user profile

6NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 12:05 am

@JavierMaki wrote:It's fine no problem, sad you updated the vita but it's ok, there's a possibility that 3.63 runs ARK or Adrenaline, try to mess with the compilers, the unofficial patch is like the DEMO release, so setup properly your compilers to fit HLBSP, that is supported by the game, old worldcraft is not good for it Frown
If I were to send you the file, could you try to see what is wrong? Maybe fix it too? I am new to this and making maps.

View user profile

7NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 12:57 am

Okay, I found something in the console. There is an error message that says "Host_Error: Couldn't load halflife wad "decals.wad"."What can I do to fix this?

View user profile

8NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 7:02 am

@jofishwright wrote:Okay, I found something in the console. There is an error message that says "Host_Error: Couldn't load halflife wad "decals.wad"."What can I do to fix this?

On the CSG parameters on the compiler just add the following line -wadinclude usedwad

Should look like this screenshot I found on Gamebanana, sorry for the advertise it has:



Hope this fix your problem ^-^


____________________________________________________________________________________________________
Der Riese WIP - My project for NZP
Valve Hammer Editor Setting up for mapping!

Actual Gaming Rig
View user profile

9NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 6:15 pm

I did this and I got an error saying "no such file or directory".

View user profile

10NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 6:25 pm

Is there anything I can do if I lead it directly to the wad using it's directory? What exactly would I use as the parameters with decals.wad?

View user profile

11NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 6:44 pm

There's no another way to include the wad inside the bsp without that parameter, so find around if you put the line correctly, it's just -wadinclude wadused (in this case, decals) or maybe you can try -nowadinclude without more values.


____________________________________________________________________________________________________
Der Riese WIP - My project for NZP
Valve Hammer Editor Setting up for mapping!

Actual Gaming Rig
View user profile

12NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 7:09 pm

So this is what I entered, but I get two error messages during and after I run it.

View user profile

13NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 8:16 pm

Here's all the files that Worldcraft created for the map.

If you end up fixing it, could you send the new file? I'll give you credit if I end up releasing it. It's just something I made when I was bored.


Looks like I'll have to send it to you through pm if I can.

And apparently I can't even do that.
Never mind.
Attachments
Alone.zip
You don't have permission to download attachments.
(39 Kb) Downloaded 3 times

View user profile

14NZP 1.1 Re: Map Wont Load! on Mon Apr 03, 2017 10:20 pm

Sorry if the map is the resemblance of a ground up cat, this is the first time making a map, and I only half-ass read the guide for it.

View user profile

15NZP 1.1 Re: Map Wont Load! on Tue Apr 04, 2017 10:35 am

I can't do nothing since the error will keep in your PC, mine can compile it perfectly so... I suggest you to update your tools to JACK Hammer tools, it can be found easy and it have a free version on their official website. That tool have all things you will need since Worldcraft is very old tool and outdated, try it out and come back if you have problems with that ^-^

JACK Tool


____________________________________________________________________________________________________
Der Riese WIP - My project for NZP
Valve Hammer Editor Setting up for mapping!

Actual Gaming Rig
View user profile

16NZP 1.1 Re: Map Wont Load! on Tue Apr 04, 2017 1:21 pm

Okay , thanks. I'm at school now , so there isn't much I can do right now. I'll get on it once I get home.

View user profile

17NZP 1.1 Re: Map Wont Load! on Thu Apr 06, 2017 12:32 am

Everything is good now, except for J.A.C.K. giving me an error message EVERY SINGLE TIME I RUN THE MAP saying that the .prt file was not created.
I'm still not able to play the map. :'(

View user profile

18NZP 1.1 Re: Map Wont Load! on Thu Apr 06, 2017 9:03 pm

I tried making another simple map that is just a room, and it compiled just fine. I guess something just went wrong with the map. Anyway, I'm okay now, thanks for the help. Smilez

View user profile

19NZP 1.1 Re: Map Wont Load! on Thu Apr 06, 2017 9:33 pm

@jofishwright wrote:I tried making another simple map that is just a room, and it compiled just fine. I guess something just went wrong with the map. Anyway, I'm okay now, thanks for the help. Smilez

Glad that JACK solved many of your problems, I was waiting for another report on the progress, so have fun then ^-^


____________________________________________________________________________________________________
Der Riese WIP - My project for NZP
Valve Hammer Editor Setting up for mapping!

Actual Gaming Rig
View user profile

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum